[xubuntu] Laptop display issues, freezes
 

[xubuntu] Laptop display issues, freezes

 
I have just installed Xubuntu 20.04.1 on an Acer Swift 3 with ryzen7 and I am having issues with the display which I suspect is due to driver problems.
The main problem is GUI freezes. These seem to be triggered by the xfce power manager trying to blank the display (after 15 minutes inactivity by default).
I have also proven that the screensaver triggers the problem, by enabling this and adjusting the inactivity time.

The freeze symptoms are that although the cursor moves, all mouse clicks and keyboard input stop reaching the desktop. I have to Ctrl-Alt-F1 and then “systemctl restart lightdm” to get the desktop working again, but this of course kills all running windows.

Another lesser issue is that the screen brightness controls (both keyboard buttons and in the system tray power manager slider) have no effect.

Some info for starters – an extract from lshw:

Code:

    *-cpu
          product: AMD Ryzen 7 4700U with Radeon Graphics
          vendor: Advanced Micro Devices [AMD]
          physical id: 1
          bus info: [email protected]
          size: 1397MHz
          capacity: 2GHz
          width: 64 bits
...

          *-display UNCLAIMED
                description: VGA compatible controller
                product: Renoir
                vendor: Advanced Micro Devices, Inc. [AMD/ATI]
                physical id: 0
                bus info: [email protected]:03:00.0
                version: c2
                width: 64 bits
                clock: 33MHz
                capabilities: vga_controller bus_master cap_list
                configuration: latency=0
                resources: memory:b0000000-bfffffff memory:c0000000-c01fffff ioport:1000(size=256) memor


and from lspci -v:

Code:

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c2) (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Renoir
        Flags: bus master, fast devsel, latency 0, IRQ 255
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        Memory at c0000000 (64-bit, prefetchable) [size=2M]
        I/O ports at 1000 [disabled] [size=256]
        Memory at c0600000 (32-bit, non-prefetchable) [size=512K]
        Capabilities:
        Kernel modules: amdgpu


Any help would be much appreciated.

 

Previous [ubuntu] VirtualBox Ubuntu wont restart after running tasksel
Next Samba Timestamps issue
 

About author

You might also like

Ubuntu Dsicussions 0 Comments

[lubuntu] Lubuntu can run Windows programs and is possible add MATE ?

Hello. The number of Linux versions and distributions make difficulties to choice what is the good version for me. I’m a Windows advanced user and I dislike how Windows manage

Ubuntu Dsicussions 0 Comments

Encryption at rest with Ceph

Do you have a big data center? Do you have terabytes of confidential data stored in that data center? Are you worried that your data might be exposed to malicious

Ubuntu Dsicussions 0 Comments

[ubuntu_mate] RAID 1 file compare errors

I have a Ubuntu mate installation with 2 raid 1 arrays of 4GB each (total 4 4GB drives, Raid arrays were created with mdadm) When I copy l(using caja) arge

0 Comments

No Comments Yet!

You can be first to comment this post!

Leave a Reply