[ubuntu] Ubuntu 20.04.1 LTS won't boot – frozen at dell splash screen
 

[ubuntu] Ubuntu 20.04.1 LTS won't boot – frozen at dell splash screen

 
hoping i can signal-boost a post i made on askubuntu yesterday, or get an answer here. post link

post text:

dell xps 15 7590 (Core i7-9750H) (NVIDIA GeForce GTX 1650, 4 GB, GDDR5)

ubuntu 20.04.1 LTS (laptop shipped with win10 – wiped windows and installed ubuntu ~1 month ago)

bios version 1.8.1

as of 5 days ago laptop boot freezes at dell splash (“ubuntu” never appears at the bottom). only difference between this boot and last successful one was that i had a hdmi connecting laptop to a monitor this time (never connected previously, during boot or otherwise). have been trying to repair this weekend with no joy.

thru `Esc` -> `Advanced options for Ubuntu` i can boot recovery mode just fine. the os partition seems okay.

dell pre-boot diagnostics returns all-clear, but then says “no bootable device” when it tries to boot.

there are many posts here regarding boot issues. i’ve tried what i can to no avail. things i have tried:

  • booting older kernels (5.4.0-45-generic and 5.4.0-42-generic)
  • disabling secure boot (BIOS system info says “signed firmware update is enabled” so i didn’t expect this to work. also there’s been no bios update since ubuntu install)
  • disabling all options in bios boot order (ubuntu, ubuntu firmware updates, windows boot manager), created new boot option for shimx64.efi, then rebooting
  • replacing “quiet splash” with “nomodeset” in /etc/default/grub (i’ve read about nvidia issues)
  • boot repair from usb, “recommended” option. only difference now is on boot dell logo appears, disappears for 3 seconds, reappears. pastebin results. i also ran the “boot info summary” option (after “recommended”… my mistake) and have this pastebin
  • in recovery mode i checked /var/log/dmesg and syslog for *obvious* signs of error. they might as well be written in klingon! 🙂
  • in recovery mode i tried updating grub bootloader, tho i think boot repair already did this
  • from usb “Try Ubuntu”, i checked filesystem:
Code:

sudo fdisk -l
Device          Start      End  Sectors  Size Type
/dev/nvme0n1p1    2048  1050623  1048576  512M EFI System
/dev/nvme0n1p2 1050624 500117503 499066880  238G Linux filesystem

sudo fsck -f /dev/nvme0n1p2
fsck from util-linux 2.34
e2fsck 1.45.5 (07-Jan-2020)

Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure```
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/nvme0n1p2: 288820/15597568 files (0.8% non-contiguous), 5256908/62383360 blocks


any help would be appreciated. if there’s more info required let me know. i could reinstall the os again but i want to know why this happened and how to prevent it in the future

output of

Code:

lspci -k | grep -EA3 'VGA|3D|Display'


:

Code:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
        DeviceName: Onboard IGD
        Subsystem: Dell UHD Graphics 630 (Mobile)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
--
01:00.0 3D controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
        Subsytem: Dell TU117M [GeForce GTX 1650 Mobile / Max-Q]         Kernel driver in use: nvidia
        Kernal modules: nvidiafb, nvidia_drm, nvidia


edit: formatting

 

Previous HP Pavillion Gaming 15 Wifi Issue
Next NVIDIA’s Ariel Kit Explains How NVIDIA BlueField DPUs Are Redefining Data Center Services
 

About author

You might also like

Ubuntu Dsicussions 0 Comments

Unable to install AWUS036ACH drivers

Hello Team, I am trying to install Alfa AWUS036ACH USB wireless adapter to Ubuntu 20.04.1 LTS but I am unable to get it working. My wireless-info.txt contents can be displayed

Ubuntu Dsicussions 0 Comments

[ubuntu] Auto-activation and not turning-off of Airplane Mode

My Lappy : HP Pavilion-15 ab030tx . After getting out of sleep mode, Flight Mode automatically gets activated and it stucks . Even on hiting the airplane mode key in

Ubuntu Dsicussions 0 Comments

Reaper is recording, but I can't hear the output when I listen to recording

Not sure what I did or didn’t tweak in the past week, but it was working perfectly 3 days ago. I do seem to have to restart the machine to

0 Comments

No Comments Yet!

You can be first to comment this post!

Leave a Reply