[ubuntu] grub-install failed error when installing ubuntu on new MacBook Air

[ubuntu] grub-install failed error when installing ubuntu on new MacBook Air

   

Hi, I am new to Linux and wanted to try it out. I recently got a new MacBook Air and wanted to dual boot Ubuntu on it. I am currently trying to install Ubuntu version: 20.04. I followed a few tutorials online and everything seemed to be going well (partitioning, creating a boot drive, installing eRFInd, etc..) until I finally started installing Ubuntu. Every time I tried to installed it, I ran into the error: “grub-install /dev/nvme0n1p4”. From what I understand /dev/nvme0n1p4 is the partition that I set aside for ubuntu to use. I have tried to find a fix for this, but the majority of what I have found is for Windows(I still tried following some of these) or simply doesn’t work. The most promising fix was running “boot-repair-disk” through the terminal. However, this too kept running into errors and I had a hard time deciphering the text output. Does anyone have any ideas on how I might be able to fix this? Should I be using a different version of Ubuntu, or not be using eRFInd? I heard that new MacBooks sometimes have problems installing Linux. Is my laptop just too new? Thanks!

 

Previous [ubuntu] OpenVPN looping
Next Remove dashes from filenames

About author

You might also like

Ubuntu Dsicussions 0 Comments

USB stick takes very long time

I have a very large USB stick (512GB) that does very long time to load compared to my other sticks (5minutes sometimes). Does anybody have idea why this is, and

Ubuntu Dsicussions 0 Comments

[ubuntu] Passwords and upgrading/updating the OS

Greetings, Yes, it seems that I have a few problems with my computer. First, the computer is a Dell Inspiron-3268 and has a 1 TB internal hard drive. Up until

Ubuntu Dsicussions 0 Comments

Where have an driver for MODEM Huawei E173 ?

Lubuntu 20.04 not have drivers for MODEM Huawei E173 ? I need to download an driver using windows and after install in Lubuntu because I not use wifi or LAN

0 Comments

No Comments Yet!

You can be first to comment this post!

Leave a Reply