Ubuntu 20.04 library cant be installed no matter what trying to install steam.
 

Ubuntu 20.04 library cant be installed no matter what trying to install steam.

 
I cant install steam no matter what i try. Dependencieo over dependencies … you got it.
Its so frustrating. Please help me. I tried anything i could, and ended up damaging my sistem. Now its like new. here is a tutorial i followed: https://linuxconfig.org/how-to-insta…al-fossa-linux
here is what happens when i do
sudo apt install steam:
[email protected]:~/steam$ sudo apt-get install steam
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
steam:i386 : Depends: libgl1-mesa-dri:i386 (>= 17.3) but it is not going to be installed or
libtxc-dxtn0:i386 but it is not installable
Depends: libgl1-mesa-glx:i386 but it is not going to be installed
Depends: libudev1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I tried reconfiguring and adding repositories and anything i could, but that libgl1-mesa problem is still there.

Also, the real problem comes when i launch steam installer. Here is what happens:

Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1:i386, libc6:i386
[sudo] password for techguy:
……
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1:i386 : Depends: libglx0:i386 (= 1.3.1-1) but it is not going to be installed
libgl1-mesa-dri:i386 : Depends: libglapi-mesa:i386 (= 20.0.4-2ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Press return to continue:

Any ideas?

 

Previous Bluetooth mouse can't reconnect after resume, Ubuntu 20.10
Next [ubuntu] install 20.04 on a system running 12.04 in parallel and on two separate hds
 

About author

You might also like

Ubuntu Dsicussions 0 Comments
Ubuntu Dsicussions 0 Comments

Loading All USA 🇺🇸 Banks 🏦 and Credit card 💳 without upfront needed

Hello Everyone I’m a Direct loader loading all kind of Bank 🏦 Account ,Credit card 💳Credit union and PayPal account 🙏✅✅Note#I load and we split no upfront needed 🙏Rippers Stay

Ubuntu Dsicussions 0 Comments

Crida a la participació en la Festa d'Instal·lació 20.10

El dissabte 14 de novembre de 2020 se celebrarà la festa de llançament de la versió 20.10 de l’Ubuntu, novament per Internet. És per això que se us convida a

0 Comments

No Comments Yet!

You can be first to comment this post!

Leave a Reply